Initial Configuration Dialog

0
15

Lab Prerequisites:

  • If You’re using GNS3 than load the Free CCNA Workbook GNS3 topology and start R1 than establish a console session with R1.

Lab Objectives:

  • Familiarize yourself with the Initial Configuration Dialog.

Lab Instruction:

When opening a brand new Cisco box rather it be a Cisco Switch or Router, after booting the device you’ll be prompted by the Initial Configuration Dialog. You’ll also be prompted by this dialog if you do the write erase command in privileged mode and reload the device as it erases the contents of NVRAM. When a Cisco device does not have a startup-config located in NVRAM, the device will prompt you rather or not to start the Initial Configuration Dialog.

Another reason as to why you may see this is that your configuration register is set to 0x2142 which ignores the contents of NVRAM upon boot which is commonly used for password recovery.

As shown below in the configuration box you’ll see the Initial Configuration Dialog prompt; select yes and press return.

 

         — System Configuration Dialog —

Would you like to enter the initial configuration dialog? [yes/no]: yes

 

After starting the System Configuration Dialog, the step by step process is relatively easy and the dialog will explain options in details. This lab will only demonstrate the basic management configuration, however it is up to you to walk through the entire system configuration dialog by typing no at the 2nd prompt as shown below;

 

At any point you may enter a question mark ‘?’ for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets ‘[]’.
Basic management setup configures only enough connectivity for management of the system, extended setup will ask you to configure each interface on the system
Would you like to enter basic management setup? [yes/no]: yes

 

After typing yes at the basic management setup prompt you’ll be given the options to configure the hostname and passwords as shown below;

 

Configuring global parameters:

Enter host name [Router]: R1

The enable secret is a password used to protect access to privileged EXEC and configuration modes. This password, after entered, becomes encrypted in
the configuration.
Enter enable secret: CISCO

The enable password is used when you do not specify an enable secret password, with some older software versions, and some boot images.
Enter enable password: cisco

The virtual terminal password is used to protect access to the router over a network interface.
Enter virtual terminal password: cisco

 

After setting the passwords in the basic management dialog, you’ll be prompted to enable SNMP (Simple Network Management Protocol) which is an industry standard protocol to allow device management via an API. After you say yes to this option you’ll be required to configure a snmp community string as shown below;

 

Configure SNMP Network Management? [no]: yes
Community string [public]: COMMUNITYSTRINGGOESHERE

After configuring the SNMP options you’ll be required to configure a single interface within the management network, keep in mind you’ll need to type out the entire name of the interface as shown below;

 

Current interface summary

Any interface listed with OK? value “NO” does not have a valid configuration

Interface                            IP-Address           OK?          Method          Status        Protocol
FastEthernet0/0               unassigned          NO           unset              up               up
FastEthernet0/1               unassigned          NO           unset              up               up
Serial1/0                           unassigned          NO           unset              up               down
Serial1/1                           unassigned          NO           unset              up               down
Serial1/2                           unassigned          NO           unset              up               down
Serial1/3                           unassigned          NO           unset              up               down

Enter interface name used to connect to the management network from the above interface summary: FastEthernet0/0

 

Once you’ve selected an interface that will participate in the management network, you’re required to configure the IP parameters for that interface as shown below;

 

Configuring interface FastEthernet0/0:
Operate in full-duplex mode? [no]:
Configure IP on this interface? [yes]:
IP address for this interface: 10.1.1.1
Subnet mask for this interface [255.0.0.0] : 255.255.255.0
Class A network is 10.0.0.0, 24 subnet bits; mask is /24

Once you’ve set those options the router will display a script of the changes to be made to the running configuration as shown below;

 

The following configuration command script was created:

hostname R1
enable secret 5 $1$kGQ2$tr6bd7mW9zjqzfkUHhnCE0
enable password cisco
line vty 0 4
password cisco
no snmp-server
!
no ip routing
!
interface FastEthernet0/0
no shutdown
half-duplex
ip address 10.1.1.1 255.255.255.0
no mop enabled
!
interface FastEthernet0/1
shutdown
no ip address
!
interface Serial1/0
shutdown
no ip address
!
interface Serial1/1
shutdown
no ip address
!
interface Serial1/2
shutdown
no ip address
!
interface Serial1/3
shutdown
no ip address
!
end

 

Afterwards the router gives you the option to save that configuration, start setup over again or disregard the setup information you just provided to the initial configuration dialog. For this lab I’m going to accept the configuration by entering option 2 to save the configuration to NVRAM and exit to CLI.

 

[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.

Enter your selection [2]: 2
The enable password you have chosen is the same as your enable secret.
This is not recommended.  Re-enter the enable password.

Building configuration…
Use the enabled mode ‘configure’ command to modify this configuration.
% Crashinfo may not be recovered at bootflash:crashinfo
% This file system device reports an error

Press RETURN to get started!

R1>

 

LEAVE A REPLY

Please enter your comment!
Please enter your name here

This site uses Akismet to reduce spam. Learn how your comment data is processed.